Back to overview
Downtime

Elevated API Latency

Nov 9, 2025 at 5:12pm UTC
Affected services
API
Developer API

Resolved
Nov 9, 2025 at 6:47pm UTC

Outrage resolved

Updated
Nov 9, 2025 at 6:24pm UTC

We have identified the problem and are working quickly towards a fix.

Updated
Nov 9, 2025 at 6:11pm UTC

We are now investigating this as an impacting incident. We are continuing to investigate.

Updated
Nov 9, 2025 at 5:34pm UTC

We have identified this to be an upstream issue with a proxy provider. We are deploying a solution with a new provider.

Created
Nov 9, 2025 at 5:12pm UTC

We are currently investigating elevated API latency across the site.