Back to overview
Degraded

Gmail.com Users Unable to Receive Verification Emails

Jul 06 at 01:48am BST
Affected services
Web App

Resolved
Jul 07 at 07:54am BST

This issue has now cleared and deliverability to Gmail accounts is good.

Created
Jul 06 at 01:48am BST

Users signing up with Gmail addresses may not receive verification emails temporarily due to Google ratelimiting. We are monitoring the situation closely.